不定期戯言

戻る

« | 2019 | Jan Feb Mar Apr May Jun Jul Aug Sep Oct Nov Dec | »

2019.07.29 (Mon)

WaPENの配列の比較

・WaPENで,配列の値が等しいかどうかを調べられるようにした。以前サイコロを60回振って各目の出た回数を表示するプログラムを作らせたとき,全部10になるまでループを回すように書いた生徒がいるのだが,それはこの配列の比較ができてなかったのでうまく動かなかったのだ。これでようやく彼の作ったプログラムが正当化できる。

コメント(3)

わたやん wrote at 2019-07-29 20:40:

こんなプログラムです…というのを作ってたらバグが1つ見つかったのでついでに直した。

整数 a[5],b,c,n
n←0
繰り返し,
|a←[0,0,0,0,0,0]
|n←n+1
|b を 1 から 60 まで 1 ずつ増やしながら,
||c←random(5)
||a[c]←a[c]+1
|を繰り返す
|nとaを表示する
を, a=[10,10,10,10,10,10] になるまで実行する

のぐー wrote at 2019-08-01 11:41:

比較だけ?
代入とか加減乗除とか全部(明示的ループ組まずに)書けると便利だと昔から思っているが。
もっとも二次元配列の掛け算は単純な要素どうしの掛け算と解釈すべきかそれとも線形代数的な行列の掛け算と解釈すべきかとかモンダイある気もするが。

わたやん wrote at 2019-08-01 11:48:

PythonのnumpyやRのベクトルみたいな感じの計算ですよね。それはどうするか正直悩みました。今後考えてみます。

コメントの受付は終了しました。

トラックバック(0)

トラックバックの受付は終了しました。